Seja um Mestre do Excel com a Fórmula INDIRETO()

O que a Fórmula Indireto Faz?

A fórmula INDIRETO ou INDIRECT no Excel é pouco conhecida, até mesmo por pessoas que se julgam especialistas no programa. No entanto, os benefícios do uso da mesma são inimagináveis.

Curso de excel básico e intermediário online

A função dela é facilitar a busca de valores dentro de uma planilha utilizando referências de texto. As variáveis dela são bem simples: =INDIRETO(texto_ref;a1). texto_ref é uma referência a uma célula que contém uma referência em estilo A1, uma referência em estilo L1C1, um nome definido como uma referência ou uma referência a uma célula como uma sequência de caracteres de texto. Se texto_ref não for uma referência de célula válida, INDIRETO retorna o valor de erro #REF!.

a1 é uma variável lógica opcional. Se for VERDADEIRO ou omitida, texto_ref será interpretada como uma variável no estilo A1. Se for FALSO, texto_ref será interpretada como variável L1C1.

É difícil de explicar por escrito, mas podemos fazer um simples exemplo prático para que você entenda:
a) Escreva seu nome na célula A1
b) Escreva na célula C1: =INDIRETO(“A1”) – as aspas são necessárias pois a referência deve ser textual.
c) Seu nome aparecerá escrito na célula C1

A referência também pode ser feita através de fórmula. Veja outro exemplo:
a) Escreva seu nome na célula A1
b) Escreva A1 na célula B1
c) Escreva na célula C1: =INDIRETO(B1) – as aspas não são mais necessárias pois a referência agora é de uma célula com conteúdo textual.
d) Seu nome aparecerá escrito na célula C1

Essa introdução mostrou para que serve a fórmula indireto, mas ainda não é possível verificar os benefícios claros do uso dela. É isso que tentaremos mostrar nas próximas partes do nosso artigo.

Aplicações Práticas da Fórmula Indireto

A fórmula INDIRETO existe para facilitar a sua vida em algumas situações. A principal delas é quando você tem uma sheet de controle com um item e você precisa buscar suas características em sheets diferentes.

Por exemplo, vamos supor que você queira criar uma planilha para controlar seus gastos pessoais. Nesta planilha você vai ter uma sheet para cada mês do ano e uma sheet principal com análises do mês que você escolheu. Uma forma de fazer isso, seria utilizando funções condicionais, mas imagina o trabalho que daria fazer um “SE” para cada mês… Vamos montar a planilha desta forma:
INDIRETO 1

Reparem que a planilha tem um campo para escolher o mês que será analisado, uma lista de meses (apenas para fazer uma lista suspensa) e sheets para cada mês. Ao criar a lista suspensa, através da validação de dados (clique aqui e saiba como fazer), o campo de escolha de mês passa a ter um menu para o usuário escolher o mês que ele quer analisar.

Imagine que você precisa do valor da célula A1 do mês escolhido na sheet do mesmo. Caso você fosse buscar dados nas sheets usando Condicionais, você teria que usar uma função parecida com essa: “=SE(L3=”Janeiro”;Janeiro!A1;SE(L3=”Fevereiro”;Fevereiro!A1;SE(L3=”Março”;……)”. Esta fórmula se estenderia para todos os meses.

Curso de excel básico e intermediário online

Utilizando a função INDIRETO, você só precisa disso: “=INDIRETO(E3&”!A1″)”. Como o Excel lê isso? E3 é uma célula, por não estar entre aspas, portanto ele lê o valor da célula E3 – Janeiro. “!A1” é uma referência de texto, por estar entre aspas. & é um termo usado para unir as duas partes. Ou seja, ele lê Janeiro!A1 – Sheet Janeiro, célula A1.

Vamos fazer um teste:
1) Escreva na sheet Janeiro, célula A1 “Primeiro Mês do Ano”
2) Escreva na sheet Fevereiro, célula A1 “Segundo Mês do Ano”.
3) Depois Escreva a fórmula “=INDIRETO(E3&”!A1″)” na célula E7 da sheet Principal
4) Preencha a célula E3 da sheet Principal com “Janeiro”. A célula E7 deve mostrar o texto “Primeiro Mês do Ano”
5) Troque o conteúdo da célula E3 para “Fevereiro”. O conteúdo da célula E7 deve ter trocado para “Segundo Mês do Ano”
Veja as imagens abaixo:

INDIRETO 2

INDIRETO 3

INDIRETO 4

Há ainda a possibilidade de utilizar a fórmula INDIRETO dentro de uma fórmula PROCV ou PROCH. Vamos testar um exemplo disso:
1) Das linhas 10 a 19 na sheet Principal, na coluna A, escreva os algarismos 1 a 10.
2) Faça o mesmo na sheet Janeiro.
3) Nas linhas 10 a 19 na sheet Janeiro, na coluna B, escreva valores aleatórios como na imagem abaixo:
INDIRETO 5

4) Na sheet Principal, na célula B10, escreva a fórmula “=PROCV(A10;INDIRETO($E$3&”!A10:B19″);2;FALSO)”.
5) Arraste esta fórmula para as linhas B11 a B19 na sheet Principal.
6) Pronto! Você tem agora a mesma tabela nas duas sheets. O excel leu o conteúdo da fórmula INDIRETO como Janeiro!A10:B19, exatamente o que você colocaria na matriz do PROCV se não tivesse a fórmula.

Se você preencher todas as sheets com conteúdo semelhante, utilizando a fórmula INDIRETO você poderá criar um excelente painel na sheet Principal. Trocando o mês na célula E3, seu painel importará os dados do mês escolhido na célula correta.

Espero que a fórmula INDIRETO te ajude muito daqui para a frente!

Curso de excel básico e intermediário online

ARTIGOS MAIS RECENTES