Simplificando a função TEXTO, CONCATENAR e & do Excel

Sumário

Quando tocamos no assunto de planilhas em excel, muitas pessoas possuem uma ideia formada que trata-se de algo muito complexo. Em virtude disso é que buscamos explicar e simplificar algumas funções: TEXTO, CONCATENAR E &.

Através de modelos de planilhas, vamos auxiliar você a montar planilhas empresariais com essas funções, utilizando-as como ferramentas de gestão para o seu negócio. Vamos lá!

1 – FUNÇÃO TEXTO

Através da utilização da função TEXTO na sua planilha em excel, você pode fazer a conversão de qualquer valor numérico em um texto, bem como atribuir uma formatação.

Sintaxe:

  • valor: trata-se de qualquer valor numérico ou refere-se a qualquer valor numérico existente em uma célula na sua planilha em excel.
  • formato_texto: trata-se do valor numérico representado através de texto que está entre aspas.

Simplificando a função TEXTO, CONCATENAR e &

Exemplo:

A planilha de excel abaixo busca elucidar a média de valor de vendas semanais de cada vendedor. Utilizamos a FUNÇÃO TEXTO para representar o valor numérico ao formato de R$ 0,00.

=TEXTO(G2;”R$0,00″)

Vejamos:

Simplificando a função TEXTO, CONCATENAR e &

Passo 1: Atribuir valor.

Simplificando a função TEXTO, CONCATENAR e &

Na célula B11, atribuimos primeiro o valor numérico que se refere ao valor representado na célula G2: =TEXTO(G2;.

Passo 2: Atribuir o formato do texto:

Simplificando a função TEXTO, CONCATENAR e &

Após, inserimos o formato de texto que representará o valor em Reais: =TEXTO(G2;“R$ 0,00”). Pressionamos ENTER e pronto. A célula B11 exibirá R$ 840,00.

2 – FUNÇÃO CONCATENAR:

Através da função CONCATENAR na sua planilha em excel, você pode agrupar inúmeras sequências de caracteres em uma única sequência de texto.

Sintaxe:

  • texto1: refere-se ao primeiro item a ser concatenado e obviamente é obrigatório.
  • texto2: opicionalmente você poderá adicionar textos, os quais devem ser separados por ponto e vírgula.

Simplificando a função TEXTO, CONCATENAR e &

Exemplo: Na célula A17 buscamos descrever em forma de uma frase a média semanal de vendas do funcionário Carlos.

=CONCATENAR(A2;” ALCANÇOU “;B11;” NA MÉDIA SEMANAL “)

Simplificando a função TEXTO, CONCATENAR e &

Passo 1: Selecionar a Célula A2 que representa o nome do funcionário Carlos como TEXTO1: =CONCATENAR(A2;

Simplificando a função TEXTO, CONCATENAR e &

Passo 2: Adicionamos a palavra ALCANÇOU como TEXTO2, entre aspas e com espaços entre as aspas: =CONCATENAR(A2;” ALCANÇOU “;

Simplificando a função TEXTO, CONCATENAR e &

Passo 3: Adicionamos a célula B11 como TEXTO3, a qual representa o valor da média de valores das vendas semanais do funcionário Carlos. =CONCATENAR(A2;” ALCANÇOU “;B11

Simplificando a função TEXTO, CONCATENAR e &

Passo 4:Como TEXTO4 colocamos as palavras NA MÉDIA SEMANAL, de maneira a completar a frase, entre aspas e com espaço entre as aspas: =CONCATERNAR(A2;” ALCANÇOU “;B11; ” NA MÉDIA SEMANAL “). Pressionamos ENTER e pronto. A célula A17 exibirá a frase CARLOS ALCANÇOU R$ 840,00 NA MÉDIA SEMANAL.

3 – &:

Através do operador & você alcançará o mesmo resultado que a função CONCATENAR. Ele é recomendado para fórmulas mais curtas.

No presente exemplo, usando & alcançamos o mesmo resultado da função CONCATENAR utilizada para o funcionário Carlos.

=A3&” ALCANÇOU “&B12&” NA MÉDIA SEMANAL”

Simplificando a função TEXTO, CONCATENAR e &

A diferença é que agora não será necessário digitar =CONCATENAR.

Tão somente insira = e após a célula A3 que refere-se ao nome do funcionário CARLOS e em sequência digite &.

Após entre aspas e com espaço entre as aspas digite ALCANÇOU.

Em seguida digite & e selecione a célula B12 que refere-se ao valor da média de valor das vendas semanas do funcionário Mário. Digite &.

Por fim, novamente entre aspas e com espaço entre as aspas digite NA MÉDIA SEMANAL e clique no ENTER. A célula A18 exibirá a frase MÁRIO ALCANÇOU R$ 725,00,00 NA MÉDIA SEMANAL.

Simplificando a função TEXTO, CONCATENAR e &

Através das explicações acima, esperamos ter ajudado você a entender um pouco mais sobre as funções TEXTO, CONCATENAR e & para uma maior utilização nas suas planilhas em excel a fim de facilitar o seu trabalho através de ferramentas de gestão para planilhas empresariais.

ARTIGOS MAIS RECENTES